dependency-errors hatası ve çözümü


dependency-errors hatası ve çözümü

Merhabalar, centos 7 x64 üzerinde epel repostory aktif ettikten sonra yum ile birseyler kurmak istediginizde dependency-errors vb. gibi hatalar alabilirsiniz. Alabileceiginiz benzer bir hata cıktısını asadıda belirtiyorum. Phpmyadmin kurulumunda hata alıyorum diyorsanız işte size çözüm.

Error: Package: php-process-5.4.16-46.el7.x86_64 (base)
Requires: php-common(x86-64) = 5.4.16-46.el7
Installed: php-common-7.2.23-1.el7.remi.x86_64 (@remi-php72)
php-common(x86-64) = 7.2.23-1.el7.remi
Available: php-common-5.4.16-46.el7.x86_64 (base)
php-common(x86-64) = 5.4.16-46.el7
Error: Package: php-tidy-5.4.16-9.el7.x86_64 (epel)
Requires: php(zend-abi) = 20100525-64
Installed: php-common-7.2.23-1.el7.remi.x86_64 (@remi-php72)
php(zend-abi) = 20170718-64
Available: php-common-5.4.16-46.el7.x86_64 (base)
php(zend-abi) = 20100525-64
You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest

Hatanı nedenine ve çözümüne gelelim.  hata epel aktif edilse dahi php eger remi ile kurulmadıysa default bir php olarak algılıyor ve yum ile paket yüklemek istediginizde php versiyon uyusmazlıklarından ötürü bu hatayı alıyorsunuz.  bilginiz gibi epel de php versiyon belirtip kurulup yapılması gerekiyor. Örnegin epel ile php 7.2 kurulumu yaptınız .

PHP 7.2 ise;

yum –enablerepo=remi,remi-php72 install phpmyadmin

php 7.3 ise;

yum –enablerepo=remi,remi-php73 install phpmyadmin

php versiyonunuza göre remideki php güncelleyip komutu calıstırabilirsiniz.

dependency-errors hatası ve çözümü

log in

reset password

Back to
log in
Choose A Format
Gif
GIF format